Extension from GitHub repo for pyRevit cannot be installed

I’ve been trying to install my extension from GitHub repo with the newest pyRevit release ( and I got this error (please see the attached image).

I tried installing the extension with the previous pyRevit release ( and it works with no problems.

Has anyone experienced something I described above?

Thank you for your time.

Hi @VitalijM
It is a known bug.
A mismatch in the version of the LibGit2Sharp Dll.
It has been fixed.
You can use the latest wip installer to get the latest versions with the fix.


Thank you for the reply.

I have un-installed and installed the version as per the image above. The issue still persists.

Am I doing something wrong?

try the installer at the bottom of this page switching to develop-4 for pyRevit 4 · eirannejad/pyRevit@f576b5c · GitHub

1 Like

Jean, I have tried and this is what I get (please see below).

I will have a look tomorrow

Thank you for doing this.

This is a different message.
I just tried with the latest WIP installer and got no issue cloning and installing an extension from github

  • it may be nothing, just a restart of your command line.
  • Can you run pyrevit env and report? / version of pyRevit installed? I just want to make sure you are using the version with the fix.
  • Try installing this extension for example
pyrevit extend ui EF-Tools https://github.com/ErikFrits/EF-Tools.git --dest=C:\pyRevit --branch=main

I can confirm this installer works thanks

here are the changes I had to make coming from v4.8.8 installer:

$env:Path = "C:\Program Files\pyRevit CLI"
Start-Process -FilePath "$($pyrevitinstaller)\pyRevit.CLI_4.8.8_signed.exe" `
              -Wait `
              -ArgumentList "/exenoui /qn" > $null

To using 4.8.15 installer:

$env:Path = "C:\Program Files\pyRevit CLI\bin"
Start-Process -FilePath "$($pyrevitinstaller)\pyRevit_CLI_4.8.15.24043_admin_signed.exe" `
              -Wait `
              -ArgumentList "/VERYSILENT /NORESTART" > $null


Apologies for the late reply. It’s been a hectic week. Please see the 2 images attached.

There is a version and the error still persists. It creates pyRevit folder on C: drive which is empty. It’s as far as it goes.

As you have confirmed, it’s all good on your side, then obviously it’s me who does something in a wrong way. Let’s leave it as it is, so not to waste anyone’s time and also I can live with that at the moment as I can load the extension manually.

Thank you for your time.

1 Like