Error when opening Revit after pyRevit installation


I recently had a colleague point out that they got an error when opening Revit after installing the newest version. I already had it insalled myself, so I decided to uninstall and reinstall to see if it worked for me. I then got the same error. I also tried installing the older version and the same error appeard.

Any help would be grateful.

Hi, Sorry for the canned answer, but this is a common case: addins incompatbilities

  1. Uninstall pyRevit

    1. Delete C:\ProgramData and %AppData%\ pyRevit and pyrevit-master folders

    2. Move all Revit addins to a temporary location. Usual addins locations include:

      • %AppData%\Autodesk\Revit\Addins
      • %AppData%\Autodesk\ApplicationPlugins
      • %ProgramData%\Autodesk\Revit\Addins
      • %ProgramData%\Autodesk\ApplicationPlugins
    3. [Reboot computer]

    4. Reinstall pyRevit

    5. Started each version of Revit confirming pyRevit successfully compiled at startup.

    6. Move all Revit addins that were moved in step 3 back to their original location.
      You may want to add them one at a time and start a revit session everytime to figure out which ones are causing the issue.

1 Like

Thanks @Jean-Marc

I followed your steps, but not fully as I wanted to see would deleting the pyRevit master folders fix the issue first, but to no avail. The error still came up. So i completed the next steps by moving the addins, and then reinstalled pyRevit. I started moving the 4 main parent folders back in, to at least wittle it down to the folder, and then I was going to go through sub-folders/addins, to try find the culrpit, however, when I moved all 4 parent addin folders back, all versions of Revit opened each time. So I am non the wiser in finding the root cause. Any further thought on what it could have been? It was strange because it never happened before and I was able to install it on several workstations along with performing updates regularly. Having to do this with all my colleagues who also ran into this issue is very time consuming.

Yep, I hear you. This is the story of Dll hell and Revit add-ons.
To track which one is unhappy is tough. The concept to retain here is loading sequence.

Once you reset the loading sequence in Whatever order (don’t look for logic too much here) add-ons and Revit are happy you are good to go.
Let’s say you have 4 add-ons, then it is 4! Possibilities to reset it to the right order by uninstalling and reinstalling add-ons in the right order.

1 Like

I haven’t had any issues in years myself even though I uninstall and install new add-ons all the time. I may just be lucky.

Something I learnt thanks to the dynamo team last week is using the subprocess analytics from Microsoft to know which Dll is being used first and taking precedence, by which addin, in revit.
Got an issue using dynamo in Revit 2025 due to the kinship install just last week

process explorer (Process Explorer - Sysinternals | Microsoft Learn) and startup procexp64.exe. Start Revit and reproduce the issue. With revit still open please lookup revit.exe inside the process explorer window and click on it. You should then see a list of all loaded modules (might have to hit Ctrl + L to show the modules tab)
Then you can hit Ctrl + S to save the logs.

OK, I understand. Anyway, I am happy to have solved it and i might also get lucky in that it won’t affect my whole team. Hopefully just a handful. Thanks for helping.

1 Like