Pyrevit intellisense

Hi i try to add intellisens to VS code (like in https://www.macro4bim.com/post/vscode-intellisense-for-revit )
I download all files and add to my python Intellisense:
image

settings.json:

{

    "workbench.colorTheme": "Default Dark+",

    "python.defaultInterpreterPath": "C:\\Program Files (x86)\\Microsoft Visual Studio\\Shared\\Python39_64\\python.exe",

    "git.autofetch": true,

    "window.zoomLevel": 1,

    "python.autoComplete.extraPaths": [

   

    "C:\\Users\\pawel\\AppData\\Roaming\\pyRevit-Master\\pyrevitlib",

    "C:\\Users\\pawel\\AppData\\Roaming\\Visual Studio Setup\\Iron\\ironpython-stubs-master\\release\\stubs.min"

    ],

    "python.analysis.extraPaths": [

        "C:\\Users\\pawel\\AppData\\Roaming\\pyRevit-Master\\pyrevitlib"

    ]

}

Folders:


image
but autocomplete doesn’t work… Anyone use vs code to write scripts and have the autocomplete?
My vs code interpreter:
image
Thank you in adwance!

A little bit of dumb stuff going on… You probably have the pylance extension downloaded. To get it to work correctly I had to go the pylance extension, click on it’s settings and then change the setting for the folder (I didn’t try workspace, so that may work) and add the folders in there. Another thing I tried that worked was disabling the pylance extension, then it worked… just not as well as it would have.

Hopefully this helps!

1 Like

Thank you! Ok so i set my pylance extra paths:

and autocompleat works but i want to ask… It is “normal” that autodesk function don’t have info and nothing after “.”?
image
image

Pyrevit works better


Do you have an idea?