Pyrevit and other addins loading sequence

Posting to see if anyone else is having similar issues. We seem to be having an office wide issue this morning and it appears to be PyRevit related…

Basically we are having issues with Revit crashing at the splash screen (all installed versions of Revit). The machines with PyRevit installed are crashing; the ones without it are opening fine.

We have used the DiRoots App Manager to turn off PyRevit loader and can get the programs to open fine…

I’ve done some testing and with the program opening fine after turning off the PyRevit loader, I will turn it back on after startup and Revit locks up and closes out. The one odd thing, I have a Revit session that is open from yesterday that is unaffected by any of this…

Any ideas to the source of this problem/next troubleshooting steps? I have exhausted what little “IT” troubleshooting knowledge I have…

Some users GitHub claim to experience a similar behaviour after installing the latest windows 10 security update - KB5034763.

Could it be that your machines received the a windows update yesterday?


Thanks for the info…I was really hoping this was going to work, but I uninstalled that security update and still having the issue…I’ll keep researching and looking for a solution.

I suggest to clean uninstall pyRevit and reinstall it.
Rename the pyrevit.addin file to 0_pyRevit.addin to make it load first.

It is most probably the update of another addin that altered the order of the loading sequence of Revit addins.

@Jean-Marc Thanks for the suggestions, tried both of these with no luck…we have our IT folks diving into this, I will report back when we have a solution.

would you be so kind to share the revit journals? that way we could help troubleshoot the error.

What also works in most cases

  • move all add-ins folders
  • uninstall then reinstall pyRevit
  • move all add-ins folders back

@sanzoghenzo Is there a secret I am missing to attaching a journal file? It doesn’t seem to let me attach it…and I tried copying/pasting the journal here but it was too long.

I changed your ‘trust’ level on the forum, you should be able to attach a file.


@Jean-Marc I still can’t seem to attach a file…the only option I see is the little picture icon labeled “Upload”. When I click on that and try to attach the journal file I get an error message.

Probably too big of a file.
Take the last hundred 2 hundred lines.

@Jean-Marc , this is the error I get…

Hey all, I don’t know exactly what out IT folks did, but it was another “SentinelOne” issue. They had to exclude a “file hash”. We are back up and running now!

Really appreciate the responses and effort to help me out!


If you can get to know what was done exactly that would be extremely helpful

This is what they sent me:

Exlcuded SentinelOne from scanning the Hash of Revit 2020 & 2023
SHA1(Revit 2020):
SHA1(Revit 2023):

Thanks Kyle, very useful
I will add the information to our article about installation issues and sentinelOne.

Where is this article?

Please, kindly find it here: Notion – The all-in-one workspace for your notes, tasks, wikis, and databases.