Linkify buttons not working

Just got a new computer. Windows 11. Installed Revit, latest pyRevit, and added my custom extension folder. It appears that my scripts are running just fine. But when I try to use a button or clickable element in an output console window for instance a button generated by linkify it does nothing. Can’t seem to find an error, warning, or anything. Just does nothing.

Any suggestions?

Any thoughts on this?

Did you change CSS for custom one? If you did, try change it for default. Does your linkify button consist of two parts? - First part with the ElementID (just selecting the element) and one with magnifier glass (finding and zooming in the element). edit- I have just seen your screenshots on github - this is not relvant, buttons seems ok :slight_smile:

How I understand it the main part of the linkify feature is written here:
I would try to debug it there.

And the last choice: Have you tried to clone the repo again? :slight_smile:
You mentioned Defender on github: have you tried to temorarily disable it whether it makes any change?

1 Like

So I have been diving into this deeper.
It does seem to be an issue with a default Microsoft baseline security setting that Intune/Defender applies to the machine.

What is the method, terminology, api, or whatever that handles the clicking on links in the pyrevit output window? There are like 200 settings in this one policy and I know if I turn it off the buttons work, and I’ve been trying to target things but not having much luck. Is it MK protocol? Scriptlets? Java? Javascript? Win 32 App calls? Considered Macros? .NET internet explorer components?

I looked in the pyrevit source code and couldn’t find revit:// or outputhelpers anywhere else. I assume it is part of a framework or compiled file that I can’t search to dig deeper.