Custom Extension Directory not working

I’ve been trying to fix my custom extensions not working for other users for weeks now, and with the new release of pyRevit, I thought I’d try removing all trace of previous versions and start fresh.
I’ve installed pyRevit (v4.8.13.23182+2215), using Revit 2023.1.2. I set the Custom Extension Directory within the pyRevit settings, when I reload, nothing happens, and it wipes the folder path.
This is the same for every one of my users that tries it.
What are we doing wrong? The extension has worked with previous versions of Revit & pyRevit.
I was looking to learn how to use the CLI to push pyRevit to all practice members, but it seems pointless without the custom extensions we have built.

Hi Dan,
Hard to tell from the information you provide.

I suggest that you try with a minimal setup.
I did a 1 button extension, it is zipped here

In there, you have the minimum data required for an extension (you actually have extra because the extension.json is not required, only if you want to see the extension listed in the Extensions builtin function of pyRevit UI or install from CLI locally)

  1. unzip in a new folder: New folder > my.extension > …
  2. add the New folder in the pyrevit settings section, _ note that the folder you need to point to is the folder CONTAINING the .extension folder, not the .extension folder itself, which is a common mistake _
  3. save and reload

you should see:

  1. the my tab

  2. the path to new forlder saved in the pyrevit settings custom extension path

  3. the my extension listed in the Extensions function of the pyRevit UI

thought: you may consider deleting the pyrevit_config file in the %appdata%/pyrevit folder to clear your setup after uninstalling.

Hi Jean-Marc,

I have the same issue. I tried the sample extension you provided here, also deleted the pyrevit_config and installed again, but my extension doesn’t show up as a new tab. The custom extension path is deleted from the settings everytime I reload. I’ve tried both pyrevit 4.8.12 and 4.8.13 and on both Revit 2023 an 2024. No luck!

Hi @Koosha, mine worked after a full uninstall (including removing the program folders) and reinstall.

@Koosha :point_up_2: this is the most common issue.

Possible test:
if you have pyRevit installed and run this command this should add an extension after reload of pyRevit or restart of revit

pyrevit extend ui pyBiltNA --dest="C:\pyRevit"

I have the same issue. I’ve completely removed everything from my previous pyRevit installation including %AppData% information. However, the custom Extensions Directories don’t seem to save. The same setup works on my Windows 10 computers but not on Windows 11. I am referencing the parent folder, not the one with .extension

Any help would be greatly appreciated :slight_smile:

1 Like

finding this 2months later - coming in v.late to pyRevit (love it!) and running into the same.

last night first-play: running no issues on:
Windows 10 running Revit 2019.2.2 + pyRevit v.4.8.8

this morning, copy (zipped then extracted) customisation folder to:
Windows 11 running Revit 2023.1.2 + pyRevit v.4.8.13


  1. cleaned out the %appdata% folder = no change
  2. updated both machines to latest release (v.4.8.14) :
    Win10 machine (w/ 2019) continues to load/work as before
    Win11 machine (w/ 2023*) continues to refuse to load the customisation**
    *same result testing w/ Revit 2021.1.8 same.
    **tested when saved in both a local C: and networked path

“looks” like a Win11 problem to me?

Please advise

Hi Kieren, my system did end up working after a full uninstall and wipe, then reinstalling. It’s worth noting that simply uninstalling pyRevit isn’t enough, you need to head into the Program Files & Program Data folders and delete all traced of pyRevit before reinstalling.

I’ve had to do this on a number of PCs across my practice, all running Windows 11 and Revit 2023, and it is behaving nicely now.

1 Like

Hi Dan, glad to hear you found a fixed, I have yet to come up lucky - despite having wiped every *pyRevit (named) item found on C: after an uninstall.


I even committed the cardinal sin of running CCleaner before and after a restart (you never know) scrubbing C: and Registry before reinstalling*

What I’m finding odd is that (after all of the above) pyRevit doesn’t “trigger” Revit into the “new addin allow” msg AND remembers the path I last pointed at - suggesting I’ve missed a file somewhere in my scrubbing.

*this has all been with pyRevit_4.8.14.24016_admin_signed.exe btw

Sooooo, because I was using “admin_signed” variant, I thought it couldn’t hurt to try the “regular” one (not that that’s ideal as I’d like to deploy this to all our peeps’ machines) but that made NO difference whatsover.

So one last scrub, and an install v4.8.8, and hurrah, a (not so) “new addin” prompt, but then…

IronPython Traceback:
Traceback (most recent call last):
File Files\pyRevit-Master\bin\engines\", line 30, in
File Files\pyRevit-Master\pyrevitlib\pyrevit\loader\", line 23, in
File Files\pyRevit-Master\pyrevitlib\pyrevit\coreutils\", line 6, in
File Files\pyRevit-Master\pyrevitlib\pyrevit\", line 773, in
Exception: Failed seeding config file. I The process cannot access the file because it is being used by another process.

I’ve still not got my head round Dynamo’s Iron Vs C stuff so not sure where to go from here. Except the pub.