Changing ironpython engine is disabled in Core setting

Greetings to all,
after two days of frustration I’m reaching out here for some help.
I’m trying to do some API calls for a pluging that I’m developing but I get an error when It reached the request library code although I have added __fullframeengine__=True in my main script and all modules that I created.

I tested my functions individually outside of revit and they work fine.
I have tried using CPython (although I’m not sure I did everything right).
according to this post the solution is to use a different engine.

But the drop down list in pyrevit setting is disabled. I see there are different engines in pyrevit-Master > bin > engines.

How can I change the engine?

So this is the solution:

  1. create a clone. Here I named mine base0.
    pyrevit clone base0 base --dest="C:\pyRevit"

  2. attach it to revit with the desired engine. here I have only one version of Revit installed (2022).
    pyrevit attach base0 2711 --installed

  3. checking if it worked.
    pyrevit attached


1 Like