Can't install PyRevit

Can’t install Pyrevit even after whitelisting the installer. It breaks Revit22 after installing it. I must uninstall and reinstall the program for it to work. Need help! Thanks in advanced

First things first,
Hello, hi, bonjour, welcome.

  1. Check the solved issues here
    Issues · eirannejad/pyRevit · GitHub

  2. If you have sentinel one… Look no further… You will have to make some exceptions in the s1 settings

  3. If you have many addins to Revit (welcome to dll hell), deactivate all of them, then activate them one by one and start Revit between every activation to figure out which one is the issue. Usually, adding a 0- in front of the pyrevit.addin file fixed it.

And file a new issue in the GitHub repo if nothing helps

And remember, no one can help / guide you if you don’t provide a little bit of context.

Thank you. I wish I knew how to do what you are asking as I do not use the product but I am IT and I support the user. What exceptions will I have to make in Sentinel One other than to allow the install?

-Tried the solution of adding the 0- in front of the installer and no-go.
-Allowed installer in Sent 1
Need a little more help

Have a look at How to convinced the BIM department to RE-install pyRevit - #6 by Jean-Marc

the two links to the github issues will provide you with enough details to configure sentinel one and make Revit + pyRevit work

The newer version of Pyrevit installs just fine. I never figured out why we had one laptop that it would not install on.

1 Like